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dApplications split on levels

JJ2EE Design Patterns




APPLICATION
SERVERS

4 In the 90’s, systems should be client-server

First tier Second tier
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O Today, enterprise applications use the multi-tier model
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APPLICATION
SERVERS

d “Multi-tier applications” have several independent
components

O An application server provides the infrastructure and
services to run such applications

O Application server products can be separated into 3
categories:
 J2EE-based solutions
 Non-J2EE solutions (PHP, ColdFusion, Perl, etc.)

1 And the Microsoft solution (ASP/COM and now .NET with
ASP.NET, VB.NET, C#, etc.)




J2EE APPLICATION
SERVERS

O Major J2EE products:

1 BEA WebLogic

- IBM WebSphere

 Sun iPlanet Application Server
 Oracle 91AS

1 HP/Bluestone Total-e-Server
J Borland AppServer

 Jboss (free open source)




J2EE

O Itis a public specification that embodies several
technologies

d Current versionis 1.3

O J2EE defines a model for developing multi-tier, web based,
enterprise applications with distributed components

J Benefits

. High availability
 Scalability
 Integration with existing systems

1 Freedom to choose vendors of application servers, tools,
components

 Multi-platform




J2EE

d Main Components

 JavaServer Pages (JSP)
 Used for web pages with dynamic content
J Processes HTTP requests (non-blocking call-and-return)

J Accepts HTML tags, special JSP tags, and scriptlets of Java
code

] Separates static content from presentation logic
1 Can be created by web designer using HTML tools

 Serviet
1 Enterprise JavaBeans (EJB)




J2EE

d Main Components

 JavaServer Pages (JSP)

 Servlet
J Used for web pages with dynamic content
J Processes HTTP requests (non-blocking call-and-return)
 Written in Java; uses print statements to render HTML
J Loaded into memory once and then called many times
 Provides APIs for session management

1 Enterprise JavaBeans (EJB)




J2EE

d Main Components

 JavaServer Pages (JSP)
 Servlet

 Enterprise JavaBeans (EJB)

d EJBs are distributed components used to implement
business logic (no Ul)

(1 Developer concentrates on business logic

 Availability, scalability, security, interoperability and
integrability handled by the J2EE server

J Client of EJBs can be JSPs, servlets, other EJBs and
external aplications

J Clients see interfaces




J2EE
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APPLICATIONS SPLIT
ON LEVELS

D
Client Level
Application clients, applets, others GUIs
< 4
. )
Prezentation level -
JSP, Servlets and others Ul elements
(. 4
4 =
Business level > J2EE Faftrens
EJB and others business resources
& 4
a I
Integration level
JMS, JDBC, Connecters .
€ -4
& )
Resource level
Data bases, external systems, resources




PATTERNS
CLASSIFICATION

O Patterns applicable on presentation level
O Patterns applicable on business level

O Patterns applicable on integration level
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PRESENTATION
PATTERNS

Intercepting Filter
Front Controller
Context Object
Application Controller
View Helper
Composite View

Service to Worker

U 0O 00000 D

Dispatcher View




PRESENTATIONS

PATTERNS

 Intercepting Filter » Facilitates pre/post

Q Front Controller request/respons
processing

 Context Object

d APphC&thﬂ Controller > Useful for security

d View Helper check, caching,

0 Composite View packaging

 Service to Worker

O Dispatcher View » Independent chain

filtering




PRESENTATION PATTERNS.
INTERCEPTING FILTER

Business
Control Display :

Client .
' Logic . Service

Intercepting
Filter




PRESENTATION PATTERNS.
INTERCEPTING FILTER

O Problem

L You want to intercept and manipulate a request and a response before
and after the request is processed.

O Example
<%
if (session.getAttribute(“user”’) == null) {
/lredirect to a login page

}

%>

O Examples

 Has the client a valid session?

O The request satisfies all the constraints?

L What encoding is used to pass date?

[ Is the request stream encoded or compressed?
O From which browser came the request?




PRESENTATION PATTERNS.
INTERCEPTING FILTER

L Forces

J You want centralized, common processing across
reguests, such as checking the data-encoding scheme of
each request, logging information about each request, or
compressing an outgoing response.

 You want pre and postprocessing components loosely
coupled with core requesthandling services to facilitate
unobtrusive addition and removal.

[ You want pre and postprocessing components
Independent of each other and self contained to facilitate
reuse.




PRESENTATION PATTERNS.
INTERCEPTING FILTER

1 Solution

1 Use an Intercepting Filter as a pluggable filter to pre and
postprocess requests and responses. A filter manager
combines loosely coupled filters in a chain, delegating
control to the appropriate filter. In this way, you can add,
remove, and combine these filters in various ways without
changing existing code.

0 Examples

[ Servlets Filter for HTTP request/responce
1 Message Handles for SOAP request/responce




PRESENTATION PATTERNS.
INTERCEPTING FILTER. STRUCTURE

Client FiterManager Target

Filter One

QO Filter
O Filter which will performs certain task prior or after  [ftercan
execution of request by request handler.

Filter Two

Fliter Three

O Filter Chain
O Filter Chain carries multiple filters and help to execute
them in defined order on target.

0 Target
O Target object is the request handler

O Filter Manager
O Filter Manager manages the filters and Filter Chain.

O Client
O Client is the object who sends request to the Target
object.




PRESENTATION PATTERNS.
INTERCEPTING FILTER

Client FilterManager FilterOne FilterTwo FilterThree Target

|

| | FilterChain
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PRESENTATION PATTERNS.
INTERCEPTING FILTER

O Strategies

 Standard filters (Servlet 2.3)
 Components used in deployment descriptor

] Personalized filters
] Base filters

[ Filters based on templates




PRESENTATION PATTERNS.
INTERCEPTING FILTER

U Exemple

 Standard Filter
public class HelloWorldFilter implements Filter {
public FilterConfig filterCfg;
@Override
public void destroy() { }

@Override
public void init(FilterConfig filterCfg) throws ServletException { this.filterCfg = filterCfg;}

public void doFilter(final ServletRequest request, final ServietResponse response,
FilterChain chain) throws java.io.lOException, javax.servilet.ServletException {
System.out.printin("In Filter");
request.setAttribute("hello”, "Hello World!");
chain.doFilter(request, response);
System.out.printin("Out HelloWorldFilter");

1}




PRESENTATION PATTERNS.
INTERCEPTING FILTER

0 Exemple

] Standard Filte

J Deployment descriptor
<filter>
<filter-name>helloWorld</filter-name>
<filter-class>web.filter.baseStrategy.HelloWorldFilter </filter-class>
<[filter>
<filter-mapping>
<filter-name>helloWorld</filter-name>
<url-pattern>/jsp/filter.jsp</url-pattern>
<[filter-mapping>




PRESENTATION PATTERNS.
INTERCEPTING FILTER

0 Exemple

 Template filters focus on pre/post processing
public abstract class TemplateFilter implements Filter {
private FilterConfig filterCfg;
public void init(FilterConfig filterCfg) throws ServletException {
this.filterCfg = filterCfg;
}
public void doFilter(ServletRequest request, ServletResponse response,
FilterChain chain) throws IOException,ServiletException {
doPreProcessing(request, response);
chain.doFilter(request, response);
doPostProcessing(request, response);
}
public abstract void doPostProcessing(ServletRequest request,
ServletResponse response);
public abstract void doPreProcessing(ServletRequest request,
ServletResponse response);
public void destroy() { }




PRESENTATION PATTERNS.
INTERCEPTING FILTER

O Consequences

[ Centralizes control with loosely coupled handlers
[ Improves reusability
1 Declarative and flexible configuration

 Information sharing is inefficient
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PATTERNS

Intercepting Filter » Offers a centerlasid controller
Eront Controller for request management

Context Object ;
. » Enter point in system. It does
Application Controller not have to be too large (it
View Helper delegates attributes to
Application Controller)

Composite View
Service to Worker
Dispatcher View

COO0D000CODO

» Request processing:

1. Protocol handeling and context
transformations

2. Navigation and routing
3. Request pocessing
4. Control transfer




PRESENTATIONS
PATTERNS

Intercepting Filter » Offers a centerlasid controller
Eront Controller for request management

Context Object ;
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» Request processing:
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3. Request pocessing
4. Control transfer




PRESENTATIONS

PATTERNS

1 Intercepting Filter
4 Front Controller
d Context Object

 Application Contrc
d View Helper

d Composite View
 Service to Worker
 Dispatcher View

FrontController Dispatcher
-dispatcher: Dispatcher s -studentView: StudentView
u IR :
+FrontController() -homeView : HomeView
+isAuthenticUser() : void +Dispatcher()
+trackRequest() : void +dispatch():void
+dispatchRequest() : void
uses uses
T uses i l
FroniControllerPatiernDemo HomeView StudentView
+main() : void .
. +show() : void +show() : void




PRESENTATIONS
PATTERNS

O Intercepting Filter » Incapsulates the state in
order to avoid using

- Front Controller protocol-specific system
d Context Object Information outside of its
 Application Controller relevant context
d View Helper S Th |

. . The application
- Composite View componesnts does not
O Service to Worker havte to Ikr_ll%w HTTP '

. . protocol. They must ca

J Dispatcher View methods getXX on an

object of the context.

> Struts - ActionForm




PRESENTATIONS
PATTERNS

Intercepting Filter
Front Controller
Context Object

Application Controller

View Helper
Composite View

Service to Worker

U O 00000 D

Dispatcher View

You want to centralize and modularize
action and view management.

You want to reuse action and view-
management code.

You want to improve request-handling
extensibility, such as adding use case
functionality to an application
incrementally.

You want to improve code modularity
and maintainability, making it easier to
extend the application and easier to test
discrete parts of your request-handling
code independent of a web container.

Struts




PRESENTATIONS
PATTERNS

: : » You want to separate a view from
O Intercepting Filter its processing logic.
O Front Controller

- » You want to use template-based
J Context Object views, such as JSP.
3 Application Controller » You want to avoid embedding
program logic in the view.

d View Helper > You want to separate

_ _ programming logic from the view
d Composite View to facilitate division of labor

_ between software developers and

d Service to Worker web page designers.
4

Dispatcher View _
» Expresion Language, JSLT




PRESENTATIONS
PATTERNS

COoo0DO00p0 0D

Intercepting Filter
Front Controller
Context Object
Application Controller
View Helper
Composite View
Service to Worker
Dispatcher View

Vertical menu

Left menu
zone

B

Content Zone

»Creates and agregates
views from atomic
components

> Tiles




PRESENTATIONS
PATTERNS

O Intercepting Filter > You Wanrt] toc|13|_erformdcore
request handling an
. Front Controller invoke business logic
d Context Object before control is passed to
- the view

d Application Controller

d View Helper _

O Composite Vi » Use Service to Worker to
OMPOSIE View centralize control and

O Service to Worker request handling to retrieve
. . a presentation model

J Dispatcher View before turning control over

to the view. The view
generates a dynamic
response based on the
presentation model.




PRESENTATIONS
PATTERNS

O Intercepting Filter » You want a view to handle a
request and generate a
- Front Controller response, while managing
4 Context Object limited amounts of
 Application Controller business processing.
d View Helper _ _ _
0 c te Vi » Use Dispatcher View with
OMPpOsite View views as the initial access
Q Service to Worker Eom_t for arequest. .
. . usiness processing, i
J Dispatcher View necessary in limited form,

IS managed by the views.




BUSINESS PATTERNS

Do O0O0O00D0D00

Business Delegate >
Service Locator

Session Facade
Application Service >
Business Object
Composite Entity
Transfer Object >
Transfer Object Assembler
Value List Handler

>

>

You want to hide clients from the complexity of
remote communication with business service
components.

You want to access the business-tier
components from your presentation-tier
components and clients, such as devices, web
services, and rich clients.

You want to minimize coupling between clients
and the business services, thus hiding the
underlying |mplementat|on details of the
service, such as lookup and access.

You want to avoid unnecessary invocation of
remote services.

You want to translate network exceptions into
application or user exceptions.

You want to hide the details of service creation,
reconfiguration, and invocation retries from the
clients.




BUSINESS PATTERNS

O Business Delegate » You want to transparently locate
busines components and services in a

O Service Locator )
uniform manner

 Session Facade
-l Application Service » Use a Service Locator to implement
] Business Object and encapsulate service and

0 Composite Entity component lookup.

0 Transfer Object » A Service Locator hides the
_ Implementation details of the lookup
1 Transfer Object mechanism and encapsulates related
Assembler dependencies.

1 Value List Handler




BUSINESS PATTERNS

] Business Delegate > You want to expose business
: mponen nd services to remote
 Service Locator gﬁenrt)g ents a

1 Session Facade

-l Application Service o, ;.0 5 Session Facade to encapsulate

1 Business Object business-tier components and expose
a coarse-grained service to remote

1 Composite Entity clients

- Transfer Obj_eCt » Clients access a Session Facade
d Transfer Object Instead of accessing business
Assembler components directly

1 Value List Handler




BUSINESS PATTERNS

A Business Delegate » You want to centralize business logic
across several business-tier

J Service Locator components and services

1 Session Facade

- Application Servicg. yse an Application Service to
Q Business Object centralize and aggregate behavior to

. . rovide a uniform service
1 Composite Entity P

d Transfer Object

d Transfer Object
Assembler

1 Value List Handler




BUSINESS PATTERNS

 Business Delegate > You have a conceptual domain model

O Service Locator with business logic and relationship

] Session Facade

» Use Business Objects to separate
business data and logic using an

O Business Object object model.

1 Application Service

1 Composite Entity
d Transfer Object

d Transfer Object
Assembler

1 Value List Handler




BUSINESS PATTERNS

 Business Delegate » You want to use entity beans to
implement your conceptual domain

1 Service Locator
model.

d Session Facade
- Application Service ;.o o Composite Entity to implement

1 Business Object persistent Business Objects using

Q Composite Entity local entity beans and POJOs.

0 Transfer Object » Composite Entity aggregates a set of
related Business Objects into coarse-

d Transfer Object grained entity bean implementations.
Assembler

1 Value List Handler




BUSINESS PATTERNS

O Business Delegate > You want to transfer multiple data

- lemen ver atier
Q Service Locator elements over atie

] Session Facade
» Use a Transfer Object to carry multiple

-l Application Service o2 elements across a tier.

1 Business Object
1 Composite Entity
 Transfer Object

d Transfer Object
Assembler

1 Value List Handler




BUSINESS PATTERNS

O Business Delegate > You want to obtain an application
model that aggregates transfer objects

O Service Locator :
from several business components.

] Session Facade

1 Application Service
1 Business Object

1 Composite Entity
d Transfer Object

1 Transfer Object
Assembler

1 Value List Handler




BUSINESS PATTERNS

O Business Delegate > You have a remote client that wants to

- iter ver a large results list.
QO Service Locator terate over alarg

d Session Facade

» Use a Value List Handler to search,
cache the results, and allow the client

O Business Object to traverse and select items from the

results

1 Application Service

1 Composite Entity
d Transfer Object

d Transfer Object
Assembler

1 Value List Handler




BUSINESS PATTERNS

O Business Delegate > Use a Value List Handler to search,

 Service Locator

] Session Facade

1 Application Service
1 Business Object

1 Composite Entity
d Transfer Object

d Transfer Object
Assembler

1 Value List Handler

cache the results, and allow the client
to traverse and select items from the
results




BUSINESS PATTERNS

1 Business Delegate » Will be discussed in detail at the next
course

1 Service Locator

1 Session Facade

1 Application Service
1 Business Object

1 Composite Entity
d Transfer Object

d Transfer Object
Assembler

1 Value List Handler




INTEGRATION
PATTERNS

1 Data Access Object

] Service Activator

J Domain Store

d Web Service Broker




